PHP güncellemesinin gerekli olduğunu nasıl anlarız ve güncelleme nasıl yapılır ?

/ 5 Eylül 2019 / 81 / yorumsuz
PHP güncellemesinin gerekli olduğunu nasıl anlarız ve güncelleme nasıl yapılır ?

Merhabalar bugün sizlere  WordPress de ”PHP güncellemesi gerekli” ve bunu nasıl güncellememiz gerekiyor, güncellemeden sonra ” Bu sayfa çalışmıyor.. şu anda bunu işleme alamıyor Http error 500” hatası karşımıza çıktığında çözümü nedir ? Bunlardan bahsedeceğim.

WordPress yeni güncelleme yaptıktan sonra sitenin güvenilir olmayan PHP sürümünde olduğunu tespit eden bir mesaj ortaya çıktı. Site yetkililerini ilk çıktığında baya kötü etkileyen bu uyarının nedeni aslında sitenin daha güvenilir ve daha iyi çalışabilmesi için yeni sürüme yani PHP7.3 sürümüne geçilmesi gerektiğini söylüyorlar.

Bugün bizde sizlere ayrıntılı olarak bu sorundan ve güncelleme nasıl yapılabilir onlardan bahsedeceğiz. Uyarı geldikten sonra ve güncelleme yapıldıktan sonra çıkan sorunlar için gerekli adımları aşağıda sizlerle paylaşacağım.

Öncelikle PHP nedir ve sistemi nasıl etkiliyor bundan bahsedelim. PHP  WordPress’i oluşturmak ve sürdürmek için kullanılan bir program dilidir. PHP’ni daha yeni sürümleri hem daha hızlı hem daha güvenilirdir, bu nedenle güncellemenin sitenizin performansını olumlu yönde etkileyecektir.

PHP nasıl güncellenir şimdide bunu açıklayalım;

WHM arama kısmına ”multiphp manager” yazalım buradan ilgili bölüme ulaşacağız. Alternatif bir site adı veya ip ile sunucuya eriştikten sonra sonuna ”/2087/cpsess4948045960/scripts2/multiphp_manager/config”  ekleyelim ve girelim.

Sol kısımda çıkacak olan ekranın üzerine dokunalım, sağda site veya siteler açılacak ilgili sitenin PHP versiyon adı altında güncelleme sürümleri çıkacak. Buradan PHP 7.3 ea PHP 73 , inherit ve PHP 5.6 seçenekleri karşınıza çıkacaktır. 7.3′ ü seçip güncellemeye başlamasını bekleyin, zaten siz seçtiğiniz zaman otomatikman yüklemeye başlayacaktır.

Peki PHP güncellemesi gerekli mi ? Birazda bu konudan bahsedelim. WordPress ” site güvenli olmayan PHP üzerinde çalıştığını tespit etti ” uyarısında bulunduysa, yeni sürüm ayarlandı, daha güvenilir, daha hızlı, daha kaliteli olacağından PHP 7.3’e geçilmesi öneriliyor. En iyi şekilde optimize edilmiş güçlü sunucuları bu sorun çok etkilemez, ama her zaman güvenlik içeren güncellemeler desteklenmelidir.

Genellikle şöyle bir problem lede karşılaşabiliyoruz PHP 7.3 güncellendikten sonra site açılmıyor yada PHP 7.3 geçtikten sonra siteye giremiyorum “Bu sayfa çalışmıyor  …com şu anda bu isteği işleme alamıyor. Http error 500” hatası çıkıyor. gibi sorunlar duyuyoruz bunun çözümünü anlatacağım sizlere. Yeni PHP sürümüyle eklentilerin uyumsuzluğundan kaynaklanıyor bu tarz hatalar ya da çok az görülse de tema uyumsuzluğu veya çakışması da diyebiliriz. Site açılmıyor ise ftp’den ya da cpanel’den eklentiler klasörü ismini değiştirebilir ya da içerisine girip eklentilerin isminin sonuna 1 koyarak değiştirerek açılmasını sağlayabiliriz. Ya da bir önceki PHP sürümüne geri döndürebilirsiniz yani PHP 7.2′ döndürdüğünüzde sorun çözülecektir.

Http error 500 hatasının çözümü ise eklentileri ftp’e girerek isimlerini değiştirin. Sonlarına 1 yazarak ta bu değişimi sağlayabilirsiniz. Site açıldıktan sonra eklentileri tek tek deneyin hangi eklentiler uyumsuz onu bir deneyin. Eğer uyumsuz olan eklenti önemli değilse onu hemen silin. Ama eğer önemli bir eklentiyse, eklenti geliştiricisine mesaj atın ve ya alternatif eklentiler bulabilirsiniz. Eğer sıkıntı temada ise başka temayla değişiklik yapın. Eğer eklentilerde sorun yoksa  o zaman ftp’ye giderek tema klasörünün yedeğini alın ftp’den silin. Siteyi eski PHP sürünümüne geri çevirin. Eğer sorun temadan da kaynaklı değil ise hosting veya sunucudan kaynaklı olabilir. Nadiren de olsa port yada veri merkezi kaynaklı da olabiliyor

 


Kaynak : Eniyiandroid


_________________________________________________________________________________________________

UYARI: Web sitemiz üzerinde bulunan tüm yazılar, görseller ve tüm materyaller Eniyiandroid.com 'a aittir. Kaynak belirtilmeden site içeriği kopyalanamaz, alıntı yapılamaz, başka yerde yayınlanamaz.

Konu Hakkında Androidseverlerden daha fazla bilgi almak için görüşlerinizi yorum yaparak paylaşabilirsiniz.


1988 yılında İzmir'de doğdum. Elazığ Fırat Üniversitesi'nde Muhasebe bölümünü okudum. Yazarlık konusuna ise 23 yaşındayken bir hevesle başlayıp, her geçen gün kendimi bu işe bağlayarak yoluma devam ettim. Yaklaşık 8 yıldır bu işle meşgulüm. Kendi sitelerimi açıp defalarca satışını gerçekleştirmeme rağmen, editörlüğü bırakmadım. Yazmak bence para için tek değil, hobi amaçlı yapılan bir meslektir.